Aktualisierte Pakete für 4.0.7 in stable und testing

Neuigkeiten und Ankündigungen
Benutzeravatar
n.wenselowski
Beiträge: 2328
Registriert: 04 Apr 2013, 12:15

Aktualisierte Pakete für 4.0.7 in stable und testing

Beitragvon n.wenselowski » 17 Jul 2017, 15:15

Sehr geehrte opsi-Anwenderinnen und -Anwender,

wir haben neue Pakete in den Bereichen stable und testing veröffentlicht.

Folgende Pakete werden als Testing veröffentlicht:

localboot:
  • opsi-setup-detector (4.0.6.132-2)
  • opsi-winst (4.11.6.14-1)

opsi-linux:
  • debian8 (4.0.7.2-2)
  • opsi-linux-client-agent (4.0.7.7-2)
  • ubuntu16-04 (4.0.7.2-2)

Betriebssystem-Pakete:
  • opsi4ucs (4.0.7.5-1)
  • opsi-directory-connector (17.1-1)
  • opsi-linux-bootimage (20170620-1)
  • opsi-nagios-plugins (4.0.7.3-1)
  • opsiconfd (4.0.7.11-2)
  • opsipxecfond (4.0.7.8-1)
  • python-opsi (4.0.7.42-1)

Mit diesem Release wird der opsi-Support für OpenSUSE 13.2 eingestellt.

Weiterhin steht in Testing- und Stable eine aktualisierte winexe-Version zur Verfügung. Bitte beachten Sie, dass diese Version nicht für alle Distributionen zur Verfügung steht.


Mit freundlichen Grüßen

Niko Wenselowski

PS: Changelogs:

Die folgenden Changelogs sind auf GitHub zu finden:

Code: Alles auswählen

opsi-directory-connector (17.1-1) stable; urgency=medium

  * Improve the message by showing the DN of the element.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 12 Jul 2017 16:42:03 +0200

opsi-directory-connector (17-1) stable; urgency=medium

  * Fix displaying a log-message for handling a non-client object.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 12 Jul 2017 16:16:46 +0200

opsi-directory-connector (16-1) stable; urgency=medium

  * Fix bug where client detection would fail because of an unreferenced
    variable if the object wasn't located under CN=Computer.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 12 Jul 2017 11:30:24 +0200

opsi-directory-connector (15-2) testing; urgency=medium

  * Improving the out-of-the-box experience for most users by setting
    verify_certificate to false for connections to the opsi server.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Tue, 27 Jun 2017 15:31:28 +0200

opsi-directory-connector (15-1) testing; urgency=medium

  * Support older versions of ldap3, such as 0.9.4.2.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Mon, 19 Jun 2017 15:52:15 +0200

opsi-directory-connector (14-1) stable; urgency=medium

  * Added new options --check-directory and --check-opsi to check the
    configured connection settings.
  * A new FQDN for a client is only created if the value from the directory
    isn't yet an FQDN.
  * Check if an element is an computer does not require the keywords to
    be uppercase anymore.
  * Creation of a domain for an client does not require the keywords to
    be uppercase anymore.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Wed, 14 Jun 2017 18:04:48 +0200

opsi-directory-connector (13-4) testing; urgency=medium

  * Replace the usage of an entry_point because not all distributions
    are able to handle this properly.

 -- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 01 Jun 2017 15:10:29 +0200


Code: Alles auswählen

opsi-linux-bootimage (20170620-1) testing; urgency=medium

  * kernel 4.11.5

 -- Mathias Radtke <m.radtke@uib.de>  Tue, 20 Jun 2017 14:38:04 +0200


Code: Alles auswählen

opsi-nagios-plugins (4.0.7.3-1) stable; urgency=medium

  * small fix in help message
  * checkShortProductStatus added to supported checks

 -- Erol Ueluekmen <e.ueluekmen@uib.de>  Mon, 10 Jul 2017 11:45:33 +0200


Code: Alles auswählen

debian8 (4.0.7.2-2) stable; urgency=low

  * new property to use a custom preseed from custom folder

-- Mathias Radtke <m.radtke@uib.de> Tue Jun 06 2017 09:50:00

ubuntu16-04 (4.0.7.2-2) stable; urgency=low

  * new property to use a custom preseed from custom folder

-- Mathias Radtke <m.radtke@uib.de> Tue Jun 06 2017 09:50:00


Code: Alles auswählen

opsi-linux-client-agent (4.0.7.7-2) stable; urgency=medium

  * you may activate upgrade by setting the global var $upgrade_before_install$ to 'true'
  * at activated upgrade: fixed univention upgrade (no more release upgrade)
  * new product dependency to l-system-update
  * fix copy warning (remove -rc from copy in Files_copy_opsiclientd_static_html)
  * new global flag $distIsSystemd$
  * fixed ucs 4.2 switches

-- d.oertel <d.oertel@uib.de> Mon, 12 Jun 2017 15:00:00 + 0100

opsi-linux-client-agent (4.0.7.7-1) UNRELEASED; urgency=medium

  * Added UCS 4.2 Support

-- Mathias Radtke <m.radtke@uib.de> Wed, 7 Jun 2017 08:43:00 +0100

opsi-linux-client-agent (4.0.7.6-2) UNRELEASED; urgency=medium

  * Updated opsiclientd.service.
  * removed distribution upgrades

-- Niko Wenselowski <n.wenselowski@uib.de>  Thu, 4 May 2017 12:53:52 + 0200


Code: Alles auswählen

opsi-winst/opsi-script (4.11.6.14) stable; urgency=low

  * osparser: isNumber: now check against int64
  * osparser: new file section copy option -h (follow symlinks; default=false)
  * osfunc: support for followsymlinks:
    FileInstall.AllCopy: AllCopy Recursive: ToCopyOrNotCopy
    filecopy  : fixes #2537

-- Detlef Oertel <d.oertel@uib.de>  Thu, 29 Jun 2017:15:00:00 +0200

opsi-winst/opsi-script (4.11.6.13) stable; urgency=low

  * oswebservice: typo: lastcation
  * osbatchgui: use myStringToTColor to interpret rgb colors from ini file
  * ssl library upgrade to 1.0.2.12 (1.0.2L) (do 16.6.2017)

-- Detlef Oertel <d.oertel@uib.de>  Mon, 29 May 2017:15:00:00 +0200


Code: Alles auswählen

opsi-setup-detector (4.0.6.132-2) testing; urgency=low

 * update innounp from 0.38 to 0.46

-- d.oertel <d.oertel@uib.de> Fri, 16 June 2017 15:00:00 + 0100
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

SirTux
Beiträge: 184
Registriert: 05 Feb 2011, 18:37

Re: Aktualisierte Pakete für 4.0.7 in stable und testing

Beitragvon SirTux » 17 Jul 2017, 17:12

Hallo,

das neue opsi4ucs ist nicht installierbar, da opsi-utils 4.0.7.10 benötigt aber nicht bereitgestellt wird.

Viele Grüße,
SirTux

Benutzeravatar
n.wenselowski
Beiträge: 2328
Registriert: 04 Apr 2013, 12:15

Re: Aktualisierte Pakete für 4.0.7 in stable und testing

Beitragvon n.wenselowski » 18 Jul 2017, 09:56

Hi SirTux,

SirTux hat geschrieben:das neue opsi4ucs ist nicht installierbar, da opsi-utils 4.0.7.10 benötigt aber nicht bereitgestellt wird.

Irgendwas ist doch immer... :lol:
Ich schiebe das heute noch nach. Sorry für die Unannehmlichkeiten!


Viele Grüße

Niko
Kein Support per DM!
_________________________
opsi support - uib gmbh
For productive opsi installations we recommend support contracts.

SirTux
Beiträge: 184
Registriert: 05 Feb 2011, 18:37

Re: Aktualisierte Pakete für 4.0.7 in stable und testing

Beitragvon SirTux » 18 Jul 2017, 12:49

Kein Problem dafür ist Testing ja da ;)


Zurück zu „News“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast